ClojureDocs

Nav

Namespaces

exercise-fn

  • (exercise-fn sym)
  • (exercise-fn sym n)
  • (exercise-fn sym-or-f n fspec)
exercises the fn named by sym (a symbol) by applying it to
n (default 10) generated samples of its args spec. When fspec is
supplied its arg spec is used, and sym-or-f can be a fn.  Returns a
sequence of tuples of [args ret].